NAT IN CISCO

NAT CONFIG IN CISCO ROUTERS

4 STEP TO CONFIG NAT :
1. DEFINE INSIDE AND OUT SIDE OF YOUR NETWORK
interface FastEthernet0/0
ip address 192.168.18.1 255.255.255.0
ip nat inside


interface FastEthernet0/1
ip address 10.10.10.1 255.255.255.0
ip nat outside


2.define "pool of ip" :
this pool has ip instead of water and choice every time from one ip of that pool.
ip nat pool Memari 10.10.10.1 10.10.10.4 netmask 255.255.255.0
in this example we define 4 ip :
10.10.10.1
10.10.10.2
10.10.10.3
10.10.10.4


3.define Collection of ip that need to NAT :
access-list 1 permit 192.168.18.0 0.0.0.255


4.Define nat:
ip nat inside source list 1 pool Memari overload

Show Config of Router with Srcnat:

Router#show running-config
interface FastEthernet0/0
ip address 192.168.18.1 255.255.255.0
ip nat inside


interface FastEthernet0/1
ip address 10.10.10.1 255.255.255.0
ip nat outside


ip nat pool Memari 10.10.10.1 10.10.10.1 netmask 255.255.255.252

ip nat inside source list 1 pool Memari overload

access-list 1 permit 192.168.18.0 0.0.0.255


Download Project in Packet Tracer